Returns a normal unit vector at the given index.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ GetNormal(
int idx
)
Public Function GetNormal (
idx As Integer
) As XYZ
public:
XYZ^ GetNormal(
int idx
)
member GetNormal :
idx : int -> XYZ
Parameters
- idx Int32
-
A zero-based index. It must be consistent with the DistributionOfNormals.
Return Value
XYZ
XYZ value representing a normal unit vector.
ExceptionsException | Condition |
---|
ArgumentException |
The given value is not a valid index of a normal of the mesh.
A valid value is not negative and is smaller than the number of normals in the mesh.
|
See Also