ViewSupportsWorksharingDisplayMode Method |
Checks whether this view supports the given worksharing display mode.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool SupportsWorksharingDisplayMode(
WorksharingDisplayMode mode
)
Public Function SupportsWorksharingDisplayMode (
mode As WorksharingDisplayMode
) As Boolean
public:
bool SupportsWorksharingDisplayMode(
WorksharingDisplayMode mode
)
member SupportsWorksharingDisplayMode :
mode : WorksharingDisplayMode -> bool
Parameters
- mode WorksharingDisplayMode
-
The mode of interest.
Return Value
Boolean
Returns True if this view is a graphical view in a workshared document or if the desired mode is Off.
Returns False if this view is a non-graphical view (such as a schedule or the project browser)
or if this view is not in a workshared document.
Exceptions
Remarks
For convenience, the "Off" mode is always supported.
Other display modes are supported by graphical views in workshared documents.
See Also