FailureMessageAccessorSetCurrentResolutionType Method |
Sets the type of a resolution to be used to resolve the failure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetCurrentResolutionType(
FailureResolutionType resolutionType
)
Public Sub SetCurrentResolutionType (
resolutionType As FailureResolutionType
)
public:
void SetCurrentResolutionType(
FailureResolutionType resolutionType
)
member SetCurrentResolutionType :
resolutionType : FailureResolutionType -> unit
Parameters
- resolutionType FailureResolutionType
-
The type of failure resolution to be used to resolve the failure.
ExceptionsException | Condition |
---|
ArgumentException |
This FailureMessageAccessor has no resolution of resolutionType.
|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
InvalidOperationException |
This FailureMessageAccessor has not been properly initialized.
-or-
This FailureMessageAccessor does not have any resolutions.
|
Remarks
When FailuresAccessor is used to resolve failures, it will execute resolutions based on current resolution type.
If no current resolution type is set, the default resolution type will be used.
Setting is performed on the FailureMessageAccessor object itself, so if there are several accessors issued
for the same FailureMessage, setting of the resolution type performed on one of them does not impact the others.
See Also