ModelPathUtilsConvertUserVisiblePathToModelPath Method |
Converts a user-visible path (string) to a ModelPath.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ModelPath ConvertUserVisiblePathToModelPath(
string strPath
)
Public Shared Function ConvertUserVisiblePathToModelPath (
strPath As String
) As ModelPath
public:
static ModelPath^ ConvertUserVisiblePathToModelPath(
String^ strPath
)
static member ConvertUserVisiblePathToModelPath :
strPath : string -> ModelPath
Parameters
- strPath String
-
The path in string form, like RSN://{HostNodeName}/school/project.rvt
Return Value
ModelPath
A ModelPath representing either a server or file path.
Exceptions
Remarks
The path may be a server or file path.
See Also