RebarConstraintsManagerGetConstraintCandidatesForHandle(RebarConstrainedHandle, Reference) Method |
For shape driven rebar returns all possible RebarConstraints that will constrain RebarConstrainedHandle to the provided reference.
For free form rebar will return an empty list.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<RebarConstraint> GetConstraintCandidatesForHandle(
RebarConstrainedHandle handle,
Reference reference
)
Public Function GetConstraintCandidatesForHandle (
handle As RebarConstrainedHandle,
reference As Reference
) As IList(Of RebarConstraint)
public:
IList<RebarConstraint^>^ GetConstraintCandidatesForHandle(
RebarConstrainedHandle^ handle,
Reference^ reference
)
member GetConstraintCandidatesForHandle :
handle : RebarConstrainedHandle *
reference : Reference -> IList<RebarConstraint>
Parameters
- handle RebarConstrainedHandle
-
The RebarConstrainedHandle for which constraint candidates are sought.
- reference Reference
-
The reference you want to constrain to.
It can be a reference to any host in the model or any bar from any host.
Return Value
IListRebarConstraint
A collection of RebarConstraints
Exceptions
Remarks
Will throw exception if the provided reference cannot be used to constrain the provided rebar handle.
See Also