ConnectorConnectTo Method

Make connection between two connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ConnectTo(
	Connector connector
)

Parameters

connector  Connector
Indicate the connector will be connected to.
Exceptions
ExceptionCondition
ArgumentNullException Thrown when argument is .
ArgumentException Argument is invalid.
InvalidOperationException Thrown when two connectors with different domain types. Thrown when these two connectors fail to connect each other. Thrown when connection already exists.
Remarks
Connection success may create a new Fitting between two connectors, if necessary.
See Also