DrawContextGetCamera Method |
Gets the camera corresponding to the Revit view where rendering takes place.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Camera GetCamera()
Public Shared Function GetCamera As Camera
public:
static Camera^ GetCamera()
static member GetCamera : unit -> Camera
Return Value
Camera
The camera.
ExceptionsException | Condition |
---|
InvalidOperationException |
This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
|
See Also