PipingSystemTypeCreate Method |
Creates a new instance of a piping system type and adds it to the document.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static PipingSystemType Create(
Document ADoc,
MEPSystemClassification systemClassification,
string name
)
Public Shared Function Create (
ADoc As Document,
systemClassification As MEPSystemClassification,
name As String
) As PipingSystemType
public:
static PipingSystemType^ Create(
Document^ ADoc,
MEPSystemClassification systemClassification,
String^ name
)
static member Create :
ADoc : Document *
systemClassification : MEPSystemClassification *
name : string -> PipingSystemType
Parameters
- ADoc Document
-
The document where the element will be created and added.
- systemClassification MEPSystemClassification
-
The classification for the piping system type to be created
- name String
-
The name of the piping system type to be created.
Return Value
PipingSystemType
The newly created piping system type element.
Exceptions
See Also