CurveByPointsUtilsCreateArcThroughPoints Method |
Creates an arc through the given reference points.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static CurveElement CreateArcThroughPoints(
Document document,
ReferencePoint startPoint,
ReferencePoint endPoint,
ReferencePoint interiorPoint
)
Public Shared Function CreateArcThroughPoints (
document As Document,
startPoint As ReferencePoint,
endPoint As ReferencePoint,
interiorPoint As ReferencePoint
) As CurveElement
public:
static CurveElement^ CreateArcThroughPoints(
Document^ document,
ReferencePoint^ startPoint,
ReferencePoint^ endPoint,
ReferencePoint^ interiorPoint
)
static member CreateArcThroughPoints :
document : Document *
startPoint : ReferencePoint *
endPoint : ReferencePoint *
interiorPoint : ReferencePoint -> CurveElement
Parameters
- document Document
-
The Document.
- startPoint ReferencePoint
-
The start point of the arc.
- endPoint ReferencePoint
-
The end end of the arc.
- interiorPoint ReferencePoint
-
The interior point on the arc.
Return Value
CurveElement
The CurveElement to be created.
Exceptions
Remarks
The interiorPoint determines the orientation of the arc while startPoint and endPoint determine
the angle parameters at the ends.
See Also