FamilyInstanceGetReferenceType Method |
Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FamilyInstanceReferenceType GetReferenceType(
Reference reference
)
Public Function GetReferenceType (
reference As Reference
) As FamilyInstanceReferenceType
public:
FamilyInstanceReferenceType GetReferenceType(
Reference^ reference
)
member GetReferenceType :
reference : Reference -> FamilyInstanceReferenceType
Parameters
- reference Reference
-
The family instance reference.
Return Value
FamilyInstanceReferenceType
Returns the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference.
Returns FamilyInstanceReferenceType.NotAReference if the instance reference doesn't correspond to a reference plane or line in the family.
Exceptions
See Also