PerformanceAdviserPostWarning Method

Reports a problem detected during execution of a rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void PostWarning(
	FailureMessage message
)

Parameters

message  FailureMessage
Warning describing the problem detected by a rule.
Exceptions
ExceptionCondition
ArgumentException The message must have severity "warning".
ArgumentNullException A non-optional argument was null
InvalidOperationException Performance advisor is not executing rules.
See Also