DocumentExport(String, String, ViewSet, FBXExportOptions) Method |
Exports the document in 3D-Studio Max (FBX) format.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Export(
string folder,
string name,
ViewSet views,
FBXExportOptions options
)
Public Function Export (
folder As String,
name As String,
views As ViewSet,
options As FBXExportOptions
) As Boolean
public:
bool Export(
String^ folder,
String^ name,
ViewSet^ views,
FBXExportOptions^ options
)
member Export :
folder : string *
name : string *
views : ViewSet *
options : FBXExportOptions -> bool
Parameters
- folder String
- Output folder, into which file(s) will be exported. The folder must exist.
- name String
- Either the name of a single file or a prefix for a set of files.
If or empty, automatic naming will be used.
- views ViewSet
- Selection of views to be exported.Only 3D views are allowed.
- options FBXExportOptions
- Options applicable to the FBX format.
Return Value
BooleanFunction returns true only if all specified views are exported successfully.
The function returns False if exporting of any view fails, even if some views might have been exported successfully.
Exceptions
RemarksThough the 'options' argument is not currently used,
an object still must be provided (may be ).
See Also