FabricationConnectorInfoIsBodyConnectorLocked Property |
Fabrication body connector lock.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsBodyConnectorLocked { get; set; }
Public Property IsBodyConnectorLocked As Boolean
Get
Set
public:
property bool IsBodyConnectorLocked {
bool get ();
void set (bool value);
}
member IsBodyConnectorLocked : bool with get, set
Property Value
Boolean
ExceptionsException | Condition |
---|
InvalidOperationException |
When setting this property: the connector cannot be modified on an owned fabrication part.
-or-
When setting this property: the connector is already connected.
-or-
When setting this property: the fabrication part is connected to more than one item.
|
Remarks
If set this prevents the connector value being overridden by the fabrication specification.
See Also