TransformCreateRotation Method |
Creates a transform that represents a rotation about the given axis at (0, 0, 0).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Transform CreateRotation(
XYZ axis,
double angle
)
Public Shared Function CreateRotation (
axis As XYZ,
angle As Double
) As Transform
public:
static Transform^ CreateRotation(
XYZ^ axis,
double angle
)
static member CreateRotation :
axis : XYZ *
angle : float -> Transform
Parameters
- axis XYZ
-
The rotation axis.
- angle Double
-
The angle.
Return Value
Transform
The new transform.
Exceptions
See Also