RebarShapeDrivenAccessorSetLayoutAsFixedNumber Method |
Sets the Layout Rule property of rebar set to FixedNumber.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetLayoutAsFixedNumber(
int numberOfBarPositions,
double arrayLength,
bool barsOnNormalSide,
bool includeFirstBar,
bool includeLastBar
)
Public Sub SetLayoutAsFixedNumber (
numberOfBarPositions As Integer,
arrayLength As Double,
barsOnNormalSide As Boolean,
includeFirstBar As Boolean,
includeLastBar As Boolean
)
public:
void SetLayoutAsFixedNumber(
int numberOfBarPositions,
double arrayLength,
bool barsOnNormalSide,
bool includeFirstBar,
bool includeLastBar
)
member SetLayoutAsFixedNumber :
numberOfBarPositions : int *
arrayLength : float *
barsOnNormalSide : bool *
includeFirstBar : bool *
includeLastBar : bool -> unit
Parameters
- numberOfBarPositions Int32
-
The number of bar positions in rebar set
- arrayLength Double
-
The distribution length of rebar set
- barsOnNormalSide Boolean
-
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
- includeFirstBar Boolean
-
Identifies if the first bar in rebar set is shown
- includeLastBar Boolean
-
Identifies if the last bar in rebar set is shown
Exceptions
Remarks
When changing the layout rule to FixedNumber, you must also simultaneously set NumberOfBarPositions,
SetLength, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.
See Also