StructuralFramingUtilsFlipEnds Method

Flips the ends of the structural framing element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void FlipEnds(
	FamilyInstance familyInstance
)

Parameters

familyInstance  FamilyInstance
The FamilyInstance, which must be of a structural framing category, non-concrete.
Exceptions
ExceptionCondition
ArgumentException The input familyInstance is concrete or is not a line, arc or ellipse element.
ArgumentNullException A non-optional argument was null
ArgumentsInconsistentException The input familyInstance is not of a structural framing category.
Remarks
Only ends of non-concrete structural framing element like beam and brace can be flipped and only in case if it is a line, arc or ellipse element.
See Also