LocationCurveJoinType Property |
Get/change the type of the join at the specified end.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic JoinType this[
int end
] { get; set; }
Public Property JoinType (
end As Integer
) As JoinType
Get
Set
public:
property JoinType JoinType[int end] {
JoinType get (int end);
void set (int end, JoinType value);
}
member JoinType : JoinType with get, set
Parameters
- end Int32
- The end of the location curve driver under question.
Property Value
JoinType
ExceptionsException | Condition |
---|
InvalidOperationException |
The element is neither a wall nor a concrete beam when it tries to get the property.
The element is not a wall when it tries to set the property.
|
InvalidOperationException |
A failure occurred while attempting to set the new type.
|
RemarksThis property allows to get join type of wall and concrete beam and to set wall's join type.
The new join type is expected to be different from the current one for this end.
See Also