TransformBasis Property

Defines the basis of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ this[
	int idx
] { get; set; }

Parameters

idx  Int32
The index of the basis vector: 0, 1 or 2.

Property Value

XYZ
Exceptions
ExceptionCondition
ArgumentOutOfRangeException Thrown when the given index is larger than 2 in the getter and setter.
InvalidOperationException Thrown when the transform is internally marked as read-only.
Remarks
This corresponds to the first three column vectors of the conventional 3x4 matrix representation.
See Also