The format of the incoming data.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public ShapeImporterSourceFormat InputFormat { get; set; } |
Visual Basic |
---|
Public Property InputFormat As ShapeImporterSourceFormat Get Set |
Visual C++ |
---|
public: property ShapeImporterSourceFormat InputFormat { ShapeImporterSourceFormat get (); void set (ShapeImporterSourceFormat value); } |
Remarks
If this option is set to Auto (the default), the file name extension will be used to determine the input format. That covers most file-based data import workflows.
Specify the input format explicitly to perform an additional sanity check or if you are using a non-standard file extension.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |