Sets the elements to be shown in the given view if they are currently hidden.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void UnhideElements( ICollection<ElementId> elementIdSet ) |
Visual Basic |
---|
Public Sub UnhideElements ( _ elementIdSet As ICollection(Of ElementId) _ ) |
Visual C++ |
---|
public: void UnhideElements( ICollection<ElementId^>^ elementIdSet ) |
Parameters
- elementIdSet
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of ElementIds to be unhidden.
Remarks
This change is permanent until the elements are hidden again.
All elements in the set must be currently hidden.
An application can check this with IsHidden(View).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the set of elements to be unhidden is empty or one of the elements can not be unhidden. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when document regeneration failed. |