Gets the property with the given name.
Namespace: Autodesk.Revit.DB.VisualAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018.1
Syntax
C# |
---|
public AssetProperty FindByName( string name ) |
Visual Basic |
---|
Public Function FindByName ( _ name As String _ ) As AssetProperty |
Visual C++ |
---|
public: AssetProperty^ FindByName( String^ name ) |
Parameters
- name
- Type: System..::..String
Name of the property.
Return Value
The property with the specified name.
Remarks
FindByName will not visit the properties of any connected asset on any of the properties.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |