Returns the normal of plane in which the hook at end of bar with index barPositionIndex that is currently in Rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2018
Syntax
C# |
---|
public XYZ GetHookPlaneNormalForBarIdx(
int end,
int barPositionIndex
) |
Visual Basic |
---|
Public Function GetHookPlaneNormalForBarIdx ( _
end As Integer, _
barPositionIndex As Integer _
) As XYZ |
Visual C++ |
---|
public:
XYZ^ GetHookPlaneNormalForBarIdx(
int end,
int barPositionIndex
) |
Parameters
- end
- Type: System..::..Int32
The end of bar. Should be 0 for start or 1 for end.
- barPositionIndex
- Type: System..::..Int32
An index between 0 and (GetNumberOfBars()-1).
Return Value
The normal of plane in which the hook at end of bar with index barPositionIndex that is currently in Rebar.
Exceptions
See Also