Initializes a new instance of the FamilyInstanceCreationData class
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public FamilyInstanceCreationData( XYZ location, FamilySymbol symbol, Level level, StructuralType structuralType ) |
Visual Basic |
---|
Public Sub New ( _ location As XYZ, _ symbol As FamilySymbol, _ level As Level, _ structuralType As StructuralType _ ) |
Visual C++ |
---|
public: FamilyInstanceCreationData( XYZ^ location, FamilySymbol^ symbol, Level^ level, StructuralType structuralType ) |
Parameters
- location
- Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
- symbol
- Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
- level
- Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
- structuralType
- Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.