Tests whether this parameter can be associated with any global parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016 Subscription Update
Syntax
C# |
---|
public bool CanBeAssociatedWithGlobalParameters() |
Visual Basic |
---|
Public Function CanBeAssociatedWithGlobalParameters As Boolean |
Visual C++ |
---|
public: bool CanBeAssociatedWithGlobalParameters() |
Return Value
True if the given parameter can be associated (is parametrizable); False otherwise.
Remarks
Only properties defined as parametrizable can be associated with global parameters.
That excludes any read-only and formula-driven parameters, as well as those that
have other explicit or implicit restrictions imposed by Revit.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This parameter does not exist in the document anymore. |