Creates a Reference with the supplied element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public Reference( Element element ) |
Visual Basic |
---|
Public Sub New ( _ element As Element _ ) |
Visual C++ |
---|
public: Reference( Element^ element ) |
Parameters
- element
- Type: Autodesk.Revit.DB..::..Element
The element to create a reference.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the parameter is nullNothingnullptra null reference (Nothing in Visual Basic). |