Indicates the lighting scheme type in rendering settings.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public enum LightingSource |
Visual Basic |
---|
Public Enumeration LightingSource |
Visual C++ |
---|
public enum class LightingSource |
Members
Member name | Description |
---|---|
ExteriorSun | Exterior source of light, sun only. |
ExteriorSunAndArtificial | Exterior source of light, sun and artificial light. |
ExteriorArtificial | Exterior source of light, artificial light only. |
InteriorSun | Interior source of light, sun only. |
InteriorSunAndArtificial | Interior source of light, sun and artificial light. |
InteriorArtificial | Interior source of light, artificial light only. |