Checks if the given vertex points are valid for the wire.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static bool AreVertexPointsValid( IList<XYZ> vertexPoints, Connector startConnector, Connector endConnector ) |
Visual Basic |
---|
Public Shared Function AreVertexPointsValid ( _ vertexPoints As IList(Of XYZ), _ startConnector As Connector, _ endConnector As Connector _ ) As Boolean |
Visual C++ |
---|
public: static bool AreVertexPointsValid( IList<XYZ^>^ vertexPoints, Connector^ startConnector, Connector^ endConnector ) |
Parameters
- vertexPoints
- Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The vertex points.
- startConnector
- Type: Autodesk.Revit.DB..::..Connector
The start connector of the wire.
- endConnector
- Type: Autodesk.Revit.DB..::..Connector
The end connector of the wire.
Return Value
True if the given vertex points are valid, false otherwise.
Remarks
X and Y values are compared of the vertices.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |