Gets the position of the rod end.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public XYZ GetRodEndPosition( int rodIndex ) |
Visual Basic |
---|
Public Function GetRodEndPosition ( _ rodIndex As Integer _ ) As XYZ |
Visual C++ |
---|
public: XYZ^ GetRodEndPosition( int rodIndex ) |
Parameters
- rodIndex
- Type: System..::..Int32
The index of the rod.
Return Value
The position of the rod end.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count. |