This class defines an enumerative type used to specify the state of a BRepBuilder object.
This enumerative type corresponds to the possible states of a BRepBuilder object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Since: 2017
Syntax
C# |
---|
public enum BRepBuilderState |
Visual Basic |
---|
Public Enumeration BRepBuilderState |
Visual C++ |
---|
public enum class BRepBuilderState |
Members
Member name | Description |
---|---|
InvalidState | BRepBuilder is in an invalid state. No further productive use is possible. |
AcceptingData | BRepBuilder is accumulating data. New b-rep components such as edges or faces may be added. |
Completed | Finish() successfully created a valid Geometry object. No new data may be added.The built object may be retrieved via GetResult(). |