Creates a new sketch plane from a reference to a planar face.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static SketchPlane Create( Document document, Reference planarFaceReference ) |
Visual Basic |
---|
Public Shared Function Create ( _ document As Document, _ planarFaceReference As Reference _ ) As SketchPlane |
Visual C++ |
---|
public: static SketchPlane^ Create( Document^ document, Reference^ planarFaceReference ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- planarFaceReference
- Type: Autodesk.Revit.DB..::..Reference
The reference of the planar face where the sketch plane will be created.
Return Value
The newly created sketch plane.
Remarks
A reference relationship will be created between the face and the sketch plane.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Sketch plane creation is not allowed in this family. -or- The reference is not a planar face. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction. |