Checks if the given vertex point can be added to this wire.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public bool IsVertexPointValid( XYZ vertexPoint ) |
Visual Basic |
---|
Public Function IsVertexPointValid ( _ vertexPoint As XYZ _ ) As Boolean |
Visual C++ |
---|
public: bool IsVertexPointValid( XYZ^ vertexPoint ) |
Parameters
- vertexPoint
- Type: Autodesk.Revit.DB..::..XYZ
The vertex point.
Return Value
True if the vertex point can be added, false if the point cannot be added because there is already a vertex at this position on the view plane (within tolerance).
Remarks
Vertices are projected to the view plane for comparison.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |