Finds the name of the 'per-document' SunAndShadowSettings that matches the properties
of this per-view element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public string GetMatchingPreset() |
Visual Basic |
---|
Public Function GetMatchingPreset As String |
Visual C++ |
---|
public: String^ GetMatchingPreset() |
Return Value
Name of the per-document SunAndShadowSettings that matches the view specific element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The SunAndShadowSettings is not view-specific. |