Creates a new FabricAreaType object with a default name.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static ElementId CreateDefaultFabricAreaType( Document aDoc ) |
Visual Basic |
---|
Public Shared Function CreateDefaultFabricAreaType ( _ aDoc As Document _ ) As ElementId |
Visual C++ |
---|
public: static ElementId^ CreateDefaultFabricAreaType( Document^ aDoc ) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
The document.
Return Value
The newly created type id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |