The category id of duct curves. It will be OST_DuctCurves, OST_FlexDuctCurves, or OST_PlaceHolderDucts.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2014

Syntax

C#
public ElementId CategoryId { get; }
Visual Basic
Public ReadOnly Property CategoryId As ElementId
	Get
Visual C++
public:
property ElementId^ CategoryId {
	ElementId^ get ();
}

See Also