Return a map of shared parameter definition groups contained within the file.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public DefinitionGroups Groups { get; } |
Visual Basic |
---|
Public ReadOnly Property Groups As DefinitionGroups Get |
Visual C++ |
---|
public: property DefinitionGroups^ Groups { DefinitionGroups^ get (); } |
Remarks
A particular group can be found by Name, using the Item property on the DefinitionGroups
object. A new group can be created by using the Create method on the DefinitionGroups Object.
The Create method takes the name of the new group, as a string, as its input parameter, returning
a reference to a new definition group object as its result.