Creates a filter rule that determines whether a parameter is associated
with a certain global parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static FilterRule CreateIsAssociatedWithGlobalParameterRule( ElementId parameter, ElementId value ) |
Visual Basic |
---|
Public Shared Function CreateIsAssociatedWithGlobalParameterRule ( _ parameter As ElementId, _ value As ElementId _ ) As FilterRule |
Visual C++ |
---|
public: static FilterRule^ CreateIsAssociatedWithGlobalParameterRule( ElementId^ parameter, ElementId^ value ) |
Parameters
- parameter
- Type: Autodesk.Revit.DB..::..ElementId
A parameter that can be associated with an existing global parameter of a compatible type.
- value
- Type: Autodesk.Revit.DB..::..ElementId
The global parameter used to test the association.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |