Gets the user-visible name for a PipeLossMethodType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static string GetLabelFor( PipeLossMethodType pipeLossMethodType, Document doc ) |
Visual Basic |
---|
Public Shared Function GetLabelFor ( _ pipeLossMethodType As PipeLossMethodType, _ doc As Document _ ) As String |
Visual C++ |
---|
public: static String^ GetLabelFor( PipeLossMethodType pipeLossMethodType, Document^ doc ) |
Parameters
- pipeLossMethodType
- Type: Autodesk.Revit.DB.Plumbing..::..PipeLossMethodType
The PipeLossMethodType to get the user-visible name.
- doc
- Type: Autodesk.Revit.DB..::..Document
The document from which to get the PipeLossMethodType.
Remarks
The name is obtained in the current Revit language.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when information for the input PipeLossMethodType cannot be found. |