Checks whether the document is in a state that allows the loading of families.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020.1
Syntax
C# |
---|
public static bool CanLoadFamilies( Document document ) |
Visual Basic |
---|
Public Shared Function CanLoadFamilies ( _ document As Document _ ) As Boolean |
Visual C++ |
---|
public: static bool CanLoadFamilies( Document^ document ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document to check.
Return Value
True if loading of families is allowed, otherwise False.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |