The material of the stairs run, only available for monolithic stairs run.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ElementId MaterialId { get; set; } |
Visual Basic |
---|
Public Property MaterialId As ElementId Get Set |
Visual C++ |
---|
public: property ElementId^ MaterialId { ElementId^ get (); void set (ElementId^ value); } |
Field Value
The id of the material of the stairs run, invalid ElementId if the stairs run is not monolithic.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The materialId is not a valid material element. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The stairs run type is not a monolithic type so the data being set is not applicable. |