Sets Hard Points for the Analytical Model.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public void SetUsesHardPoints( bool hardPoints ) |
Visual Basic |
---|
Public Sub SetUsesHardPoints ( _ hardPoints As Boolean _ ) |
Visual C++ |
---|
public: void SetUsesHardPoints( bool hardPoints ) |
Parameters
- hardPoints
- Type: System..::..Boolean
Enable/disable Hard Points (true = enable).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel cannot use Hard Points. |