Set Location path for a spiral run.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2013
Syntax
C# |
---|
public static bool SetLocationPathForSpiralRun(
StairsRun stairsRun,
XYZ center,
double radius,
double startAngle,
double includedAngle,
bool clockwise,
StairsRunJustification justification
) |
Visual Basic |
---|
Public Shared Function SetLocationPathForSpiralRun ( _
stairsRun As StairsRun, _
center As XYZ, _
radius As Double, _
startAngle As Double, _
includedAngle As Double, _
clockwise As Boolean, _
justification As StairsRunJustification _
) As Boolean |
Visual C++ |
---|
public:
static bool SetLocationPathForSpiralRun(
StairsRun^ stairsRun,
XYZ^ center,
double radius,
double startAngle,
double includedAngle,
bool clockwise,
StairsRunJustification justification
) |
Parameters
- stairsRun
- Type: Autodesk.Revit.DB.Architecture..::..StairsRun
The run whose location path will be set.
- center
- Type: Autodesk.Revit.DB..::..XYZ
The center of the location arc of the spiral run.
The Z coordinate of the center is the base elevation for the new run (in model coordinates).
It must be greater than or equal to the stairs base elevation.
- radius
- Type: System..::..Double
The radius of the location arc of the spiral run.
- startAngle
- Type: System..::..Double
The start angle of the location arc of the spiral run.
The angle's coordinate system is world coordinate system which always is XYZ.BasisX and XYZ.BasisY.
- includedAngle
- Type: System..::..Double
The total angle covered by the spiral run. Must be a positive value (direction is determined by the clockwise flag).
- clockwise
- Type: System..::..Boolean
True if the spiral run will be created along clockwise direction, False otherwise.
- justification
- Type: Autodesk.Revit.DB.Architecture..::..StairsRunJustification
The location path justification of the new stairs run.
Return Value
Indicate if set is success or not.
Exceptions
See Also