Determines whether a potential building type name is unique.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public static bool IsNameUnique( Document document, string name ) |
Visual Basic |
---|
Public Shared Function IsNameUnique ( _ document As Document, _ name As String _ ) As Boolean |
Visual C++ |
---|
public: static bool IsNameUnique( Document^ document, String^ name ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- name
- Type: System..::..String
The candidate name.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |