Obtains a list of the intrinsic wall sweeps or reveals in this CompoundStructure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public IList<WallSweepInfo> GetWallSweepsInfo( WallSweepType wallSweepType ) |
Visual Basic |
---|
Public Function GetWallSweepsInfo ( _ wallSweepType As WallSweepType _ ) As IList(Of WallSweepInfo) |
Visual C++ |
---|
public: IList<WallSweepInfo^>^ GetWallSweepsInfo( WallSweepType wallSweepType ) |
Parameters
- wallSweepType
- Type: Autodesk.Revit.DB..::..WallSweepType
Whether to obtain wall sweeps or reveals.
Return Value
An array which describes the intrinsic wall sweeps or reveals.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |