The type of heating or cooling system.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public gbXMLServiceType ServiceType { get; set; } |
Visual Basic |
---|
Public Property ServiceType As gbXMLServiceType Get Set |
Visual C++ |
---|
public: property gbXMLServiceType ServiceType { gbXMLServiceType get (); void set (gbXMLServiceType value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The service type does not fall within an appropriate range. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |