Constructs a new instance of the ImageTypeOptions object.
The provided string path must specify a local file. The path can be absolute or relative to the project's location. ImageType will respectively use an absolute or relative path.
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
[ObsoleteAttribute("This constructor is deprecated in Revit 2021 and will be removed in the next version of Revit. We suggest you instead use the constructors that take an ImageTypeSource and a path or an external resource reference as input.")] public ImageTypeOptions( string path ) |
Visual Basic |
---|
<ObsoleteAttribute("This constructor is deprecated in Revit 2021 and will be removed in the next version of Revit. We suggest you instead use the constructors that take an ImageTypeSource and a path or an external resource reference as input.")> _ Public Sub New ( _ path As String _ ) |
Visual C++ |
---|
[ObsoleteAttribute(L"This constructor is deprecated in Revit 2021 and will be removed in the next version of Revit. We suggest you instead use the constructors that take an ImageTypeSource and a path or an external resource reference as input.")] public: ImageTypeOptions( String^ path ) |
Parameters
- path
- Type: System..::..String
The file path that specifies the image to be used.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |