Retrieves the material element id of a specified layer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public ElementId GetMaterialId( int layerIdx ) |
Visual Basic |
---|
Public Function GetMaterialId ( _ layerIdx As Integer _ ) As ElementId |
Visual C++ |
---|
public: ElementId^ GetMaterialId( int layerIdx ) |
Parameters
- layerIdx
- Type: System..::..Int32
Index of a layer in the CompoundStructure.
Return Value
The material element id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range. |