Returns the RebarConstraintTargetHostFaceType of the host Element face to which
the RebarConstraint is attached. The RebarConstraintType of the RebarConstraint
must be 'FixedDistanceToHostFace' or 'ToCover.'
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public RebarConstraintTargetHostFaceType GetRebarConstraintTargetHostFaceType( int targetIndex ) |
Visual Basic |
---|
Public Function GetRebarConstraintTargetHostFaceType ( _ targetIndex As Integer _ ) As RebarConstraintTargetHostFaceType |
Visual C++ |
---|
public: RebarConstraintTargetHostFaceType GetRebarConstraintTargetHostFaceType( int targetIndex ) |
Parameters
- targetIndex
- Type: System..::..Int32
The index of the target. Should be between 0 and NumberOfTargets().
Return Value
Returns the RebarConstraintTargetHostFaceType of the host Element face to which the RebarConstraint is attached.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | targetIndex is out of range. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace' or 'ToCover.' |