Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the
current Revit context (active document, active view and active tool). False if the pushbutton is disabled because
of the active context.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool IsEnabledByContext { get; } |
Visual Basic |
---|
Public ReadOnly Property IsEnabledByContext As Boolean Get |
Visual C++ |
---|
public: property bool IsEnabledByContext { bool get (); } |
Remarks
The button may be enabled for a given context but still disabled programmatically using the Enabled property
for the button.