This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined
by a TriangulatedSolidOrShell.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public class TriangulationInterfaceForTriangulatedSolidOrShell : TriangulationInterface |
Visual Basic |
---|
Public Class TriangulationInterfaceForTriangulatedSolidOrShell _ Inherits TriangulationInterface |
Visual C++ |
---|
public ref class TriangulationInterfaceForTriangulatedSolidOrShell : public TriangulationInterface |
Remarks
The vertex and triangle indices used by this class treat the triangulated solid or shell as if all
the vertices and triangles of the different shell components were collected into single sets of vertices
and triangles, respectively. For example, if a solid has two shell components and the first has ten vertices
while the second has five vertices, vertexIndex 6 refers to vertex[6] of the first shell component, and
vertexIndex 12 refers to vertex[2] of the second shell component. You can use the class
TriangulationInterfaceForTriangulatedShellComponent to get a faceting of an individual shell component.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..TriangulationInterface
Autodesk.Revit.DB..::..TriangulationInterfaceForTriangulatedSolidOrShell
Autodesk.Revit.DB..::..TriangulationInterface
Autodesk.Revit.DB..::..TriangulationInterfaceForTriangulatedSolidOrShell