The Revision number of this revision.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public string RevisionNumber { get; } |
Visual Basic |
---|
Public ReadOnly Property RevisionNumber As String Get |
Visual C++ |
---|
public: property String^ RevisionNumber { String^ get (); } |
Remarks
Note that this field is only available if the RevisionSettings are set to number revisions PerProject.
When Revisions are numbered PerSheet, a given Revision may display a different RevisionNumber on each sheet.
In this case, the revision number can be obtained by calling [!:Autodesk::Revit::DB::ViewSheet::GetRevisionNumberOnSheet()].
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is not valid for when the revision numbering is per sheet. |